Disruption in logging into the Webmail
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Jun 10, 2021 - 11:03 EDT
Identified
We have received reports that some of our customers may be experiencing issues when attempting to log into Webmail
Posted Jun 10, 2021 - 08:30 EDT
This incident affected: Email (Webmail).