Limited functionality of Support Tools
Incident Report for ionos.ca
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted Sep 30, 2024 - 23:47 EDT
Update
We are still working on resolving this issue. More information will follow soon.
Posted Sep 30, 2024 - 15:51 EDT
Update
We are continuing to work on restoring these features (services).
Posted Sep 30, 2024 - 13:13 EDT
Update
Our technicians are currently working on resolving this issue.

Due to a technical problem, some customers are unable to download their invoices in the Control Panel.
Posted Sep 30, 2024 - 10:47 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Sep 30, 2024 - 09:20 EDT
This incident affected: Customer Service (Support Tool) and Contract Management (Billing Service).