Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Apr 17, 2020 - 10:38 EDT
Identified
Due to a technical disruption, some customers may experience issues with their domain DNS configuration.
Posted Apr 17, 2020 - 10:27 EDT
This incident affected: Domains (DNS).