Incident Report
Incident Report for ionos.ca
Resolved
We apologize for the inconvenience caused and thank you for your patience.
Posted Jun 18, 2022 - 16:29 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Jun 18, 2022 - 16:12 EDT
This incident affected: Customer Service (Support Tool).