Invoice download is not possible
Incident Report for ionos.ca
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Jan 10, 2025 - 06:58 EST
Identified
Due to a technical issue, it is not possible to download invoices in the Control Panel. Our technicians are currently working on resolving this issue.
Posted Jan 10, 2025 - 00:06 EST
This incident affected: Contract Management (Billing Service).