Incident Report for Cloud Backup
Incident Report for ionos.ca
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Nov 07, 2019 - 11:47 EST
Identified
Some customers may experience issues while using their Cloud Backup.
Posted Nov 07, 2019 - 08:44 EST
This incident affected: Servers (Cloud Server).