Support Hotline may not be reached

Incident Report for ionos.ca

Resolved

The disruption affecting the Support Hotline has been resolved. It is now functioning normally again.
Posted Apr 24, 2025 - 14:10 EDT

Identified

Due to a technical disruption, the Support hotline is temporarily unavailable. As an alternative, you can use +1 816 621 4910.

We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding.

You may also contact our support team via e-mail at support@ionos.com or via chat.
Posted Apr 23, 2025 - 17:02 EDT
This incident affected: Customer Service (Customer Hotline).