Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Jul 01, 2020 - 04:34 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service Team are not able to answer all questions related to your account.
Posted Jul 01, 2020 - 02:19 EDT
This incident affected: Customer Service (Support Tool).