Incident Report for Email Marketing
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Nov 14, 2019 - 04:21 EST
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Nov 14, 2019 - 01:46 EST
Identified
Some customers are facing issues while using their Email Marketing
Posted Nov 13, 2019 - 15:24 EST
This incident affected: Online Marketing (E-Mail Marketing).