Email address creation may not be possible
Incident Report for ionos.ca
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted Sep 05, 2024 - 05:40 EDT
Update
We are still working on resolving the technical issue. Thank you for your patience and understanding.
Posted Sep 05, 2024 - 02:18 EDT
Identified
Some customers may be experiencing issues creating email address
Posted Sep 04, 2024 - 16:13 EDT
This incident affected: IONOS (IONOS Control Panel).