Incident Report for Customer Service Support Tool
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Sep 11, 2020 - 17:45 EDT
Update
Due to a technical problem with our systems, some functions relating to invoices or payments may not be available within your account at the moment. We are working towards a swift resolution.
Posted Sep 11, 2020 - 06:25 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service Team are not able to answer all questions related to your account.
Posted Sep 11, 2020 - 05:55 EDT
This incident affected: Customer Service (Support Tool) and Contract Management (Billing Service).