Greater hold time in our Hotline
Incident Report for ionos.ca
Resolved
Thank you for your patience and understanding.
Posted Nov 29, 2021 - 07:13 EST
Identified
Due to this technical disruption there may currently be an increased call volume to our hotlines. Waiting times may therefore be longer.
Posted Nov 29, 2021 - 07:03 EST
This incident affected: Customer Service (Support Tool).