Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Jan 13, 2020 - 16:27 EST
Identified
Due to a technical disruption, recent purchases of products may be delayed during setup
Posted Jan 13, 2020 - 15:25 EST
This incident affected: Contract Management (Contract Activation).