Incident Report for webmail
Incident Report for ionos.ca
Resolved
The systems are stable and all services are functioning normally again.
Posted Apr 09, 2021 - 15:36 EDT
Identified
Some customers may experience issues while using their webmail
Posted Apr 09, 2021 - 15:01 EDT
This incident affected: Email (Webmail).