Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Mar 24, 2020 - 07:19 EDT
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted.
Posted Mar 24, 2020 - 06:34 EDT
This incident affected: Control Panel.