Email address creation may not be possible
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Apr 29, 2021 - 15:55 EDT
Identified
Some customers may be experiencing issues creating email address
Posted Apr 29, 2021 - 15:18 EDT
This incident affected: Control Panel.