Unable to view invoices in the Control Panel
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Nov 17, 2022 - 12:41 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 17, 2022 - 12:01 EST
Identified
Some customers may be unable to view their invoice in the Control Panel
Posted Nov 17, 2022 - 11:44 EST
This incident affected: IONOS (IONOS Control Panel) and Contract Management (Billing Service).