Update Payment Method May Not Be Possible

Incident Report for ionos.ca

Resolved

The issue has been resolved.
Posted Jun 30, 2026 - 19:29 EDT

Update

We are currently working on resolving the technical disruption. We will have an update for you shortly.
Posted Jun 30, 2026 - 19:16 EDT

Identified

Some customers may experience issues when updating their payment method in Control Panel. We apologize for any inconvenience this may cause you.
Posted Jun 30, 2026 - 18:48 EDT
This incident affected: Contract Management (Billing Service).