Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Feb 13, 2023 - 09:56 EST
Update
We have eliminated the disruption for some of those affected.
Posted Feb 13, 2023 - 07:51 EST
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Feb 13, 2023 - 07:34 EST
Update
We are still working on resolving the technical issue.
Posted Feb 13, 2023 - 06:02 EST
Update
Our technicians are currently working on resolving this issue.
Posted Feb 13, 2023 - 04:58 EST
Identified
Due to a technical problem, some customers may be unable to download their invoices in the Control Panel.
Posted Feb 13, 2023 - 03:46 EST
This incident affected: Contract Management (Billing Service).