Incident Report
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Oct 04, 2022 - 04:30 EDT
Identified
Due to a technical disruption, password reset services are temporarily unavailable.
Posted Oct 04, 2022 - 04:10 EDT
This incident affected: IONOS (IONOS Control Panel).