Sending e-mail to Microsoft hosted email address may not be possible
Incident Report for ionos.ca
Resolved
The issue has been resolved.
Posted Jan 26, 2021 - 16:48 EST
Identified
Email sent to Microsoft hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience caused.
Posted Jan 26, 2021 - 13:08 EST
This incident affected: Mail System and Delivery (Sending Emails).