Incident Report
Incident Report for ionos.ca
Resolved
The systems are stable and all services are functioning normally again.
Posted Aug 25, 2022 - 11:37 EDT
Identified
Some customers may be experiencing issues receiving E-mails.
Posted Aug 25, 2022 - 09:51 EDT
This incident affected: Mail System and Delivery (Receiving Emails).